Installation

The SDK currently supports Python 2.6, 2.7, 3.3, 3.4, and 3.5. The requests package is required.

We recommend using pip and virtualenv to install the SDK. Please note that the SDK’s Python package is called facebook-sdk:

Installing from Git

For the newest features, you should install the SDK directly from Git.

virtualenv facebookenv
source facebookenv/bin/activate
pip install -e git+https://github.com/mobolic/facebook-sdk.git#egg=facebook-sdk

Installing a Released Version

If your application requires maximum stability, you will want to use a version of the SDK that has been officially released.

virtualenv facebookenv
source facebookenv/bin/activate
pip install facebook-sdk